1

Topic: RLink USB Driver on Windows Vista and/or 64-bits PC

*** EDIT 25/08/2008 ***

The latest version of RIDE includes a new driver (WinUSB/RLinkWinUSB) for Windows Vista and Vista64.
You can download it there:
http://www.raisonance.com/download/index.php

You must reinstall all your RIDE kits for using the new driver.
You might also need to uninstall the old driver. (Vista32)

Note that for Windows XP and older, the old driver (Jungo/RLinkWDP) is still used.
So the comments below still apply to WinXP users.


*** END EDIT 25/08/2008 ***




The USB driver for RLink that is installed by the RIDE installer (v7.0.0) does not work on some systems with Windows Vista or 64-bits CPUs. (or both)

Here is a version (V7V) of the installation that should work in these systems (as well as the older systems):
ftp://www.raisonance.com/pub/RLink_USB_ … 080606.zip

For installing it, like for RIDE, you must have administrator rights.

Note that this version does NOT work under Windows Vista64.

2

Re: RLink USB Driver on Windows Vista and/or 64-bits PC

Troubleshooting:

If you installed the old driver (the one for XP), or if you plugged RLink before installing the Vista driver, or if your user account management is not as admin as you think (often happens in Vista), then you might be unable to install it. Here some things to try for making it work:

1. Make sure you are logged as Administrator AND run the "RLinkUSBInstall.exe" using the "run as administrator" option.

2. Here is the uninstallation procedure to follow in case you have some wrong driver loaded:

2.1. Plug the RLink, and if any driver is loaded for it, go to the device manager and ask Windows to uninstall it. I don't expect that to have much effect, but it's cleaner to try it. If you see a "Jungo" section in the device manager, please also try to uninstall it. Then, unplug the RLink.

2.2. Remove all the files, directories and reg keys (using regedit.exe started as admin) in the list below. In DriverStore, try to remove the directories. If you cannot, remove as many of the files in them as you can. Also remove the registry entries if you manage to do it. You'll need to change the ownership to yourself, recursively, then give "everyone" the complete access to the keys/directories/files, then you should be able to remove them. Being an administrator is not enough with Vista. You have to trick it all the time. ;( Here is the list of things to remove if they exist:

  files and folders:
C:\Windows\inf\Windrvr6.*
C:\Windows\inf\RLink*.*
C:\Windows\System32\Drivers\Windrvr6.*
C:\Windows\System32\Drivers\RLink*.*
C:\Windows\System32\DriverStore\FileRepository\Windrvr6*.*
C:\Windows\System32\DriverStore\FileRepository\RLink*.*
  reg keys:
"HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Enum/USB/VID_138E&PID_9000/..."

2.3. When you have removed everything you can, run RLinkUSBInstall again (in admin mode, not just while being logged as admin) leave it at least 2 minutes to complete and then plug the RLink. Check that you see the BUSY LED turning ON (means the RLink is started) and then OFF. (means the USB enumeration has been done, and therefore that the driver is correctly loaded)

3

Re: RLink USB Driver on Windows Vista and/or 64-bits PC

If you followed this complete procedure and still don't manage to use RLink, please contact us: "support@raisonance.com".

Before that, please run the uninstallation/reinstallation procedure above a second time and write down all the details about what you did, tried, succeeded, failed:
Which files and registry keys you removed, which files and registry keys you tried to remove but didn't manage, which error messages you got (if you got any), and the log of the execution of RLinkUSBInstall. (use an admin DOS prompt an redirect the output to a file)

4

Re: RLink USB Driver on Windows Vista and/or 64-bits PC

Update to the driver uninstall procedure:

Windows makes backup copies of rht inf files it installs.
You must remove these backup copies for the uninstall procedure to be complete:

Search C:\Windows\inf directory for "oem*.inf" files containing either "Jungo" or "RLink". (use grep or something similar)
Remove all those files and the associated oem*.pnf files.

To check that the uninstall procedure is complete, you must be able to plug the RLink, tell Windows to search the driver automatically, and get an answer like 'no compatible driver found'.

5

Re: RLink USB Driver on Windows Vista and/or 64-bits PC

Another update for the uninstall procedure:

In Windows XP, the driver store is called "DRVSTORE" and not "DriverStore".

So you must also search
C:\Windows\System32\DRVSTORE\FileRepository\Windrvr6*.*
C:\Windows\System32\DRVSTORE\FileRepository\RLink*.*

6

Re: RLink USB Driver on Windows Vista and/or 64-bits PC

Here is the RLink documentation, which contains mostly a summary of the USB driver problems and solutions:
ftp://www.raisonance.com/pub/RLink_USB_ … dRLink.pdf